Archive

Archive for January, 2014

Cisco diff – compare configurations

January 31, 2014 4 comments

Just a quick post to show how one can compared what is in the startup-configuration
compared to the running-configuration or to compare to different configurations
stored on flash on Cisco devices.

The device boots up with the startup-configuration. Then we add some commands to
the running-configuration but we do not save them.

R1(config)#int f0/0
R1(config-if)#ip add 192.168.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#description link to Datacenter
R1(config-if)#ip route 192.168.2.0 255.255.255.0 192.168.0.2

Then the show archive command is used to show what’s different between the two versions.

R1#show archive config differences
Contextual Config Diffs:
interface FastEthernet0/0
 +no ip address
 +shutdown
interface FastEthernet0/0
 -description link to Datacenter
 -ip address 192.168.0.1 255.255.255.0
-ip route 192.168.2.0 255.255.255.0 192.168.0.2

Commands with a + sign in front of it are present in the startup-configuration but
not in the running-configuration. If there is a – sign then they are present in the
running-configuration but not in startup-configuration.

It is also possible to compare a file stored in NVRAM to the running-configuration.

R1#dir flash:
Directory of flash:/

    1  -rw-         967                      config.old

16777212 bytes total (16776180 bytes free)

R1(config)#int f0/1
R1(config-if)#ip add 10.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#description to Firewall
R1#show archive config differences system:running-config flash:config.old
Contextual Config Diffs:
interface FastEthernet0/1
 +no ip address
 +shutdown
interface FastEthernet0/1
 -description to Firewall
 -ip address 10.0.0.1 255.255.255.0

Just a little tool that may be helpful to see what is different between versions. It
could be used for such things as editing an ACL by uploading a file to the device.
Then do a diff between the files to see what is changing in the ACL.

Cisco Learning Network VIP 2014

January 10, 2014 14 comments

I have been selected to join the Cisco Learning Network VIP program for 2014.
I’m very happy and proud to join this program as I like to give back to the
community. I try to do so by answering questions at the Cisco Learning Network
forum.

Remember that we were all beginners at one stage of or journey and hopefully
you had someone that helped you along in the beginning. It’s never too late
to give back.

Here is a brief profile at CLN on my VIP award.

You can read more about the VIP program here.

Being a VIP I hope to be able to update you more on Cisco’s learning strategy and
to be able to influence future certifiactions and the Cisco Network Academy and
things like that.

Categories: Announcement Tags: , , ,